httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laszlo Nagy <gand...@designaproduct.biz>
Subject Re: [users@httpd] NameVirtualHost + SSL certificate problem
Date Thu, 19 Oct 2006 14:25:10 GMT
Joshua Slive wrote:
> On 10/19/06, Boyle Owen <Owen.Boyle@swx.com> wrote:
>
>> Move all the SSL certificate directives for this site in here, then it
>> should work.
>
>> As soon as you start using virtual hosts, give up the idea of a "default
>> server" and put all directives in a VH container for each server...
>
> That might be the problem.  Although, in theory, config directives in
> the "default server" (main server config) should inherit into the
> vhosts if not overriden.
>
> Another possibility is that you haven't properly configured port-based
> vhosting.  Instead of <VirtualHost *:443> you should be using
> <VirtualHost _default_:443> and similarly for the other.  The "*" is
> only used in name-based virtual hosting.
Actually, I'm using name based virtual hosting. I also have these in my 
httpd.conf file:

NameVirtualHost *:80
NameVirtualHost *:443
NameVirtualHost *:444

I understand that apache can only use one certificate per IP 
address/port combination (because in the protocol, the certificate is 
needed before any hostname is sent by the browser). However, the port 
itself should identify the correct certificate. (There is only one 
certificate specified for *:444 virtual hosts, and another one for *:443 
virtual hosts.)

Best,

   Laszlo


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message