httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Hempel <li...@frankoni.net>
Subject [users@httpd] DirectoryIndex not working when mod_autoindex loaded
Date Fri, 03 Nov 2006 09:10:31 GMT
Hello,

When I have loaded the mod_autoindex additionally to the mod_dir I'm 
getting the error
"Directory index forbidden by rule: /some/dir" when I request the path 
/some/dir or /some/dir/
When I do not load autoindex, it works, that means the index.* files 
will be taken.

The DirectoyIndex rule is specified for the virtualhost telling that 
index.html and others are valid index files.
I had also read somewhere that regarding the order of the 
load-statements of mod_dir and mod_autoindex it is important to have 
mod_dir in front of mod_autoindex. This is made sure as well.

The goal is to have both modules working. In folders with no index files 
one should get a listing (from mod_autoindex) and if there is index 
files found (specified by the directorIndex rule), one shell get this 
index file.

What could I have forgotten to have both working?

Thanks for any hints,
Ciao, Frank

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message