httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob <bobsie...@googlemail.com>
Subject Re: [users@httpd] Rewrite does not work
Date Thu, 11 Jan 2007 19:48:34 GMT
Peter Huesser wrote:
> Bob wrote:
> 
>>> following entries in httpd.conf:
>>>
>>>   RewriteEngine On
>>>   RewriteCond %{REMOTE_HOST} \.domain\.ch$
>>>   RewriteRule ^/testtinfo/fea http://another.url.ch/
>>>
>>> The produced entries in rewrite.log are:
>>>
>>> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
>>> [server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (2) init rewrite engine
>>> with requested uri /testtinfo/fea
>>> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
>>> [server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (3) applying pattern
>>> '^/testtinfo/fea' to uri '/testtinfo/fea'
>>
>> This regEx should match /testtinfo/fea... Are other rules (if you call
>> /foo and have ^/foo as regEx) wirking fine?
>>
> No. I created a different rule
> 
>   RewriteEngine On
>   RewriteCond %{REMOTE_HOST} \.psi\.ch$
>   RewriteRule ^/usage http://another.url.ch/
> 
> and get the following in rewrite.log

Another thought: Did you set the directive RewritelogLevel at least to 
4? (6 = highest used). Below loglevel 4, the processing of conditions is 
not being logged.

-- 
Bob

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message