httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Huesser <peter.hues...@psi.ch>
Subject Re: [users@httpd] Rewrite does not work
Date Fri, 12 Jan 2007 09:46:19 GMT
>
> Another thought: Did you set the directive RewritelogLevel at least to
> 4? (6 = highest used). Below loglevel 4, the processing of conditions
> is not being logged.
>
Wow, that was the break-through.Had a loglevel of 3 until now. Here the
new log entries:

129.129.194.181 - - [12/Jan/2007:10:06:29 +0100]
[server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (2) init rewrite engine
with requested uri /usage/
129.129.194.181 - - [12/Jan/2007:10:06:29 +0100]
[server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (3) applying pattern
'^/usage' to uri '/usage/'
129.129.194.181 - - [12/Jan/2007:10:06:29 +0100]
[server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (4) RewriteCond:
input='129.129.194.181' pattern='\.psi\.ch$' => not-matched

I changed the RewriteCond to

RewriteCond %{REMOTE_HOST} ^129\.129\.

No it works!! Krist van Besien wrote a few mails ago "What might also be
an issue here is that reverse DNS doesn't work properly". So it seems
that he was right. I checked it on the machine (server.psi.ch) using
"nslookup IP" and I got the correct answer. Therefor I thought this
could not be the problem. But apache may to behave different.

Anyway, thanks' a lot to all.

Pedro





---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message