httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Spence <scintil...@gmail.com>
Subject [users@httpd] dyld: Undefined symbols: _compress _uncompress
Date Fri, 05 Jan 2007 20:06:03 GMT

I'm running Apache/2.2.3 (Unix) DAV/2 mod_perl/2.0.2 Perl/v5.8.1 configured
on OS X 10.3.9.  The server will start and everything appears fine, but when
I try to gracefully restart, the server stops.

The only error message I have is:

dyld: /usr/local/apache2/bin/httpd Undefined symbols:
_compress
_uncompress

According to a couple of php forums, this is a problem with the mysql client
libraries using zlib.  So I tried reinstalling mysql with a link
(--with-zlib-dir=/opt/local/) to the latest version of zlib which I
installed from DarwinPorts, but this did nothing.  Starting MySQL with
DYLD_LIBRARY_PRINT=1 seems to suggest that zlib is not even being loaded by
MySQL.  Starting Apache with DYLD_LIBRARY_PRINT=1 also suggests that Apache
is not loading zlib.

Am I totally on the wrong track with the mysql client libraries?  Can
someone point me in the right direction?
-- 
View this message in context: http://www.nabble.com/dyld%3A-Undefined-symbols%3A-_compress-_uncompress-tf2927673.html#a8184902
Sent from the Apache HTTP Server - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message