httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sander Temme <scte...@apache.org>
Subject Re: [users@httpd] Building Static Apache on AIX 5.2 with GCC
Date Mon, 08 Jan 2007 19:43:06 GMT

On Jan 5, 2007, at 6:42 AM, Justin Johnson wrote:

> My new problem is that apr-util has a problem with a statically linked
> ldap.  See below.
>
> /svn/static/build/httpd-2.2.3/srclib/apr-util>./configure \
> >      --prefix=$base_dir/apr-util-httpd \
> >      --enable-static=yes \
> >      --enable-shared=no \
> >      --with-ldap=$base_dir \
> >      --with-apr=$base_dir/apr-httpd

Did you also build apr-util?  Try specifying --with-apr-util= 
$base_dir/apr-httpd/bin/apu-1-config as well as --with-apr=$base_dir/ 
apr-httpd/bin/apr-1-config (assuming you installed them in the same  
place).

Note that you need to explicitly tell your apr-util build about -- 
with-ldap=... (in the default build config it'd inherit that from the  
httpd ./configure).

Building apr and apr-util separately is not usually required for a  
build, but it does give you finer-grained control over what gets  
generated.

When you build APR (and APR-util), does the build follow your  
specified shared/static requirements? Does the static archive  
statically link against that holy grail, the gcc runtime?

S.

-- 
sctemme@apache.org            http://www.temme.net/sander/
PGP FP: 51B4 8727 466A 0BC3 69F4  B7B8 B2BE BC40 1529 24AF



Mime
View raw message