httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sander Temme <scte...@apache.org>
Subject Re: [users@httpd] Upgrading from 2.0.49 to 2.0.59
Date Mon, 05 Feb 2007 04:52:24 GMT

On Feb 4, 2007, at 8:33 PM, m-kuriyama@terilogy.com wrote:

> Hi all,
>
> I'm planning to upgrade from 2.0.49 to 2.0.59 for securities.
> Apache is configured SSL with openssl-0.9.7d.
> What I want to know is that openssl-0.9.7d is compatible with 2.0.59.

Answer 1) can't see why not.
Answer 2) both openssl and Apache are freely available, so you can
           download them and ensure yourself that they interoperate.

> As far as I looked into doc files in openssl source , I could not find
> any information regarding compatibility.

It's not up to OpenSSL to be compatible with Apache, but the other  
way around.  I am not personally very familiar with the mod_ssl code,  
but you may see the file modules/ssl/ssl_toolkit_compat.h which  
contains some definitions that differ based on OpenSSL version.

> Somebody knows that ?

If 2.0.49 was compatible with a particular OpenSSL version, it is  
highly likely that newer versions will also be compatible with the  
same version.

S.

-- 
sctemme@apache.org            http://www.temme.net/sander/
PGP FP: 51B4 8727 466A 0BC3 69F4  B7B8 B2BE BC40 1529 24AF



Mime
View raw message