httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "thomas Armstrong" <tarmstr...@gmail.com>
Subject [users@httpd] Re: Mess with symbolic links, directory owners and "403 Forbidden" error
Date Fri, 02 Feb 2007 09:35:06 GMT
Fixed.

I changed  /var/www/mydomain/dir/common_images/ owner to 'apache.apache' and
it works now.

Thank you very much, anyway :)

On 2/2/07, thomas Armstrong <tarmstrong@gmail.com> wrote:
> Hi.
>
> Using Apache 2.0.51, I've got a VirtualHost 'mydomain.com' mounted on:
> '/var/www/mydomain/'
>
> Within this directory, I've got another directory ('test'), and within it
> one symbolic link:
> /var/www/mydomain/test/images -> /var/www/mydomain/dir/common_images/
> ------
>
> If I make 'images' owner be 'root.root' it works ok when accessing
> 'http://www.mydomain.com/test/images/foo.php', but if the owner is
> 'apache.apache' I get a '403 Forbidden error'. In both cases,
> 'foo.php' script's got execution permissions (also 'images'
> directory).
>
> How can I execute this script with 'apache.apache' owner? Thank you very much.
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message