httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark A. Craig" <mark.a.cr...@gmail.com>
Subject Re: [users@httpd] Compiling module under Windows for Apache 2.2.4 with APXS.BAT/.PL
Date Wed, 03 Oct 2007 22:11:00 GMT
Turns out there might be a good reason it wouldn't run: it's NOT for Windows 
2000... Windows XP SP2 is listed as a minimum requirement.

So I started the PSDK again, and this time I noticed that it's a WEB install, so 
when I thought it was hung it was just downloading a large file.  The install 
finished when I was more patient, and got still further, but hit YAIP (Yet 
Another Include Problem):


C:\Program Files\Apache Software Foundation\Apache2.2\bin>vsvars32.bat
Setting environment for using Microsoft Visual Studio 2005 x86 tools.

C:\Program Files\Apache Software Foundation\Apache2.2\bin>setenv.cmd /2000
Attempting to detect a Microsoft Visual Studio installation
Targeting Windows 2000 and IE 5.0 DEBUG

C:\Program Files\Apache Software Foundation\Apache2.2\bin>apxs -c -i -a mod_httpbl.c
cl  /nologo /MD /W3 /O2 /D WIN32 /D _WINDOWS /D NDEBUG 
-I"C:\PROGRA~1\APACHE~1\Apache2.2\include"  /c /Fomod_httpbl.lo mod_httpbl.c

mod_httpbl.c

mod_httpbl.c(360) : fatal error C1083: Cannot open include file: 'sys/socket.h': 
No such file or directory

apxs:Error: Command failed with rc=131072

So why am I missing this one, and what SDK do I hafta download to get it?

Mark

-------- Original Message  --------
Subject: Re: [users@httpd] Compiling module under Windows for Apache  2.2.4 with 
APXS.BAT/.PL
From: Mark A. Craig <mark.a.craig@gmail.com>
To: Mark A. Craig <mark.a.craig@gmail.com>
Date: Wednesday, October 03, 2007 02:10:51 PM

> Downloaded the SDK for "Vista and .NET 3.0 Runtime Components", and now 
> it's telling me that Setup.exe is not a valid Win32 application!  I've 
> downloaded and tried to run it three separate times now, same response 
> each time.  And yes, I downloaded it from microsoft.com.  o_O
> 
> Mark
> 
> -------- Original Message  --------
> Subject: Re: [users@httpd] Compiling module under Windows for Apache  
> 2.2.4 with APXS.BAT/.PL
> From: Mark A. Craig <mark.a.craig@gmail.com>
> To: users@httpd.apache.org
> Date: Wednesday, October 03, 2007 01:57:38 PM
> 
>> I think you're right... I'm trying to install the Platform SDK right 
>> now, and apparently it's HUNG copying files.
>>
>> *runs back outside to the pump again*
>>
>> -------- Original Message  --------
>> Subject: Re: [users@httpd] Compiling module under Windows for Apache  
>> 2.2.4 with APXS.BAT/.PL
>> From: William A. Rowe, Jr. <wrowe@rowe-clan.net>
>> To: users@httpd.apache.org
>> Date: Wednesday, October 03, 2007 01:48:18 PM
>>
>>> Mark A. Craig wrote:
>>>> You mean it doesn't come included with a WINDOWS-based compiler package
>>>> from MICROSOFT?  o_O
>>>>
>>>> And actually, in my case I'll apparently need the old-fashioned 
>>>> Platform
>>>> SDK, because I'm compiling on Windows 2000....
>>>
>>> NO - you want the modern one that integrates into VS2005.  Don't panic,
>>> it will even compile Windows NT 4 programs, still :)
>>>
>>> ---------------------------------------------------------------------
>>> The official User-To-User support forum of the Apache HTTP Server 
>>> Project.
>>> See <URL:http://httpd.apache.org/userslist.html> for more info.
>>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
>>> For additional commands, e-mail: users-help@httpd.apache.org
>>>
>>>
>>
> 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message