httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] Authentication not checked in proxied directory
Date Sun, 04 Nov 2007 17:58:06 GMT
On Sun, 04 Nov 2007 17:15:39 +0000
"Phil Endecott" <spam_from_apache_users_3@chezphil.org> wrote:

> Dear Experts,
> 
> I'm surprised to find that authentication does not seem to be checked 
> in a directory which I proxy to another local server:
> 
>          <Location /something>
>                  AuthName "my_auth_name"
>                  AuthType basic
>                  AuthPAM_Enabled off

What's that?

>                  AuthBasicProvider dbd
>                  AuthDBDUserPWQuery "...sql..."
>                  require valid-user
> 
>                  ProxyPass http://localhost:12345 smax=0 ttl=60
>                  ProxyPassReverse http://localhost:12345
>          </Location>

What "Satisfy" value and Order/Allow/deny applies?
Check your config for any other stanzas that match
(including - potentially - <Location />).

> I am able to access content from here without providing any
> credentials.

What shows up in your logs?  That'll tell you if your browser
has cached credentials.

-- 
Nick Kew

Application Development with Apache - the Apache Modules Book
http://www.apachetutor.org/

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message