httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian" <lil_ran...@usa.com>
Subject RE: [users@httpd] Apache 2.2.8 VirtuaHost and a NAS
Date Tue, 04 Mar 2008 23:50:17 GMT


William A. Rowe, Jr. wrote:

>Joshua Slive wrote:
>> On Tue, Mar 4, 2008 at 7:13 AM, Graeme Fowler <graeme@graemef.net> wrote:
>>> Hi
>>>
>>>  On Mon, 2008-03-03 at 21:10 -0900, Brian wrote:
>>>  > DocumentRoot "L:/test"
>>>
>>>  Wouldn't that be "L:\test", with a backslash?
>> 
>> No, all paths in httpd.conf should use forward slashes.
>> 
>> The problem of not being able to access network drives is typically
>> explained by running apache as a service under privileges that don't
>> allow network access (usually LocalSystem). See:
>> http://httpd.apache.org/docs/2.2/platform/windows.html#winsvc
>
>Exactly; it's also worth using //machine/share/ syntax instead of L: since
>the service control manager won't mount up L: for you.
>
>But if the service "run as" account doesn't have access to //machine/share,
>httpd won't start.  See your application event log for details.
>

Ok, thank you both to you Will and Joshua!  It works now.  First off in case
anyone tried to do something similar setting it up to run as a windows
account which has access to the NAS was already done, but I missed the step
where it had to have log on as a service modified.

1. Create a normal domain user account, and be sure to memorize its
password. 

**2. Grant the newly-created user a privilege of Log on as a service and Act
as part of the operating system. You can also manually set these via the
Local Security Policy MMC snap-in. **

3. Confirm that the created account is a member of the Users group. 
Grant the account read and execute (RX) rights to all document and script
folders (htdocs and cgi-bin for example). 

4. Grant the account change (RWXD) rights to the Apache logs directory. 

5. Grant the account read and execute (RX) rights to the httpd.exe binary
executable

Additionally I did not know until now that the service control manager would
not mount the drive even though it shows in the OS as already being mounted.
Good to know.  And yes, //<NAS name>/share/test/ did work perfectly!!  

Thanks again to both of you.

Brian



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message