httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Pifer <...@obrien-pifer.com>
Subject [users@httpd] apache2 permissions problem on SELS10SP1
Date Fri, 08 Aug 2008 11:40:17 GMT
I'm hoping someone here can give me a hand. We have an apache2 server
that has several virtual servers. Somehow they got screwed up, still not
sure how. To make a long story short, I ended up removing them all and
setting them back up again using yast2/HTTP Server tool. 

All the sites are up and answering correctly, but all of our cgi scripts
are failing with 403 errors. In the error log I get this:
[Thu Aug 07 20:47:07 2008] [error] [client ipaddress] client denied by
server configuration: /srv/www/cgi-bin/client.pl, referer:
http://server.domain.com

The config for this virtual host is:
<VirtualHost ´╗┐server.domain.com>
 DocumentRoot /srv/www/htdocs/ref/
 ServerName ´╗┐server.domain.com
 ServerAdmin admin@domain.com
 <Directory /srv/www/htdocs/ref/>
  AllowOverride None
  Order allow,deny
  Allow from all
 </Directory>
 ScriptAlias /cgi-bin/ "/srv/www/cgi-bin/"
 ErrorLog /var/log/apache2/error.com-error_log
 CustomLog /var/log/apache2/access.com-access_log common
</VirtualHost>

The files are in the cgi-bin directory, and I'm told they were working
fine before this problem started. 

wwwrun is the user owner, and root is the grp owner. I even have the
files temporarily set to 777.

Anyone have any suggestions?

Thanks,
James



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message