httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davide Bianchi <dav...@onlyforfun.net>
Subject Re: [users@httpd] problems installing apache module
Date Thu, 04 Sep 2008 06:58:27 GMT
Bill Tantzen wrote:
> The error I see when I do a configtest is:
> Syntax error on line 248 of /software/apache/conf/httpd.conf:
> Cannot load /software/apache/libexec/mod_fastcgi.so into server:
> /software/apache/libexec/mod_fastcgi.so: undefined symbol: OS_FcgiConnect

The module is trying to load a library but the library is of a different
version than expected or is not there.

> libfcgi.so is where the function is defined, and it is located in a
> non-standard directory, /software/lib.  I tried passing these options to
> apxs:

Add /software/lib to your /etc/ld.so.conf file and run (as root) ldconfig.

Davide

-- 
A four-year-old child could understand that. Run out and find me
a four-year-old child, I can't make head or tail out of it.
-- Julius Henry "Groucho" Marx (http://en.wikiquote.org/wiki/Groucho_Marx)

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message