httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bianca Taylor <>
Subject [users@httpd] /usr/lib/ could not read symbols: File in wrong format
Date Mon, 13 Oct 2008 07:29:24 GMT

We are having Apache 2.2.9 installed on a Red Hat 64-bit machine. 

I get an error when attempting to:

cpan> install Apache2::Request

The error is:

gcc -shared  .libs/util.o .libs/version.o .libs/cookie.o .libs/param.o .libs/parser.o .libs/parser_urlencoded.o
.libs/parser_header.o .libs/parser_multipart.o .libs/module.o .libs/module_custom.o .libs/module_cgi.o

.libs/error.o  -Wl,--rpath -Wl,/usr/local/apache2/lib -Wl,--rpath -Wl,/usr/local/apache2/lib
/usr/local/apache2/lib/ /usr/local/apache2/lib/ -L/usr/lib64 -L/usr/local/apache2/lib
-luuid -lrt -lcrypt -lpthread -ldl  -Wl,-soname -Wl, -o .libs/
/usr/lib/ could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[2]: *** [] Error 1
make[2]: Leaving directory `/root/.cpan/build/libapreq2-2.08-h8GWKD/library'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/.cpan/build/libapreq2-2.08-h8GWKD/library'
make: *** [all-recursive] Error 1

I went looking for it on google and if I understand correctly then this is 
looking at the wrong library, it uses the 32bit  (/usr/lib/ 
instead of 64bit version of it (/usr/lib64/

I tried various command line flags when running the ./configure file (directly 
from the /root/.cpan/build/... directory). For 
example --with-expat=xml/expat, --with-expat=builtin, --enable-lib64 --with-expat=/usr/lib64/...

I always get exactly the same error as above. 

I also saw this patch:

However the link to the Apache 2.2.4 version is dead and I am running 2.2.9.

Thanks in advance for any help.


Unisolve Pty Ltd - 
Melbourne Australia
Ph +61 3 9568 2005

The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message