httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rich Phaneuf <>
Subject [users@httpd] Configuration question.
Date Fri, 07 Nov 2008 02:02:06 GMT
Heyas all,
    I've had apache running with virtual hosts for a while now and
decided recently to add bugzilla, which means adding mod_perl.  I know
this isn't the forum for mod_perl, but I think I've moved past that
point.  At this point I'm getting permission errors in Firefox and well,
I've posted the results of a test script from bugzilla below.  I've
tried to include the applicable sections of my config files, scripts
that I've tried and their results, and file permissions.
    As for the host system, I'm running apache 2.2.9-r1 on a Gentoo
Linux box.  Which kind of complicates things because of the way the
config files are broken apart in gentoo.  I'm testing via the test
script below and Firefox (Linux) and version 3.0.3 (Vista).  In
all cases, I'm getting the same error log message, and in Firefox I'm
getting the same "Forbidden" message in both browsers.

When I run /var/www/localhost/htdocs/bugzilla/ I get the

stooges bugzilla # /var/www/localhost/htdocs/bugzilla/
TEST-OK Webserver is running under group id in $webservergroup.
TEST-OK Got front picture.
TEST-OK Webserver is executing CGIs via mod_perl/2.0.3-dev.
TEST-OK Webserver is preventing fetch of

and when I use the browser to hit

You don't have permission to access /bugzilla/ on this server.
Apache Server at Port 80

When I go look at /var/log/apache2/error-log, I see:

[Thu Nov 06 17:21:28 2008] [error] [client] client denied by
server configuration: /curly/apache2/

Now as to my apache2 configuration, here are some snippets from the
various config files.

# Virtual-host support
# Gentoo has made using virtual-hosts easy. In /etc/apache2/vhosts.d/ we
# include a default vhost (enabled by adding -D DEFAULT_VHOST to
# APACHE2_OPTS in /etc/conf.d/apache2).
Include /etc/apache2/vhosts.d/*.conf
PerlSwitches -I/var/www/localhost/html/bugzilla -w
PerlTaintCheck ON
PerlWarn ON
<Location /perl>
        SetHandler perl-script
        PerlHandler Apache::Registry
        #PerlHandler Apache::PerlRun
        Options ExecCGI FollowSymLinks
        PerlSendHeader ON
        Order allow,deny
        Allow from all

and /etc/apache2/vhosts/vhosts.conf:

        AliasMatch /perl(.*) /curly/apache2/$1
        DocumentRoot /curly/apache2/
        DirectoryIndex index.html
        LogLevel debug
        CustomLog /var/log/apache2/ combined
<Directory /curly/apache2/>
        Order allow,deny
        Allow from All
        Options FollowSymLinks Includes Multiviews
        AllowOverride All
        <IfModule mod_access.c>
                Order allow,deny
                Allow from All
<Directory /curly/apache2/>
        AddHandler perl .pl
        Options +ExecCGI Includes Multiviews +FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from All
        <IfModule mod_access.c>
                Order allow,deny
                Allow from All
        <Files /curly/apaceh2/>
                Order allow,deny
                Allow from All

The AliasMatch line I got from the mod_perl section of the 3rd edition
of O`Reilly "Apache the difinitive guide".

One thing I would like to point out, is that the actual bugzilla
installation is in /var/www/localhost/htdocs/bugzilla, with the
/var/www/ being a symbolic link to the origial
in localhost.  Here's my file permissions, in case it matters:

stooges bugzilla # ls -ld /var/www/localhost/htdocs/*
drwxr-xr-x 13 root apache 2776 Oct 30 14:29
-rwxr-xr-x  1 root root     44 Jun 30 10:12


stooges bugzilla # ls -ld /var/www/*
lrwxrwxrwx 1 root     root     35 Oct 30 09:28
/var/www/ -> /var/www/localhost/htdocs/bugzilla/
-rw-r--r-- 1 rphaneuf apache  270 Sep 18  2007

I can't change the actual permissions on the symlink from the
file, Gentoo will actually use the symlink source ownership and
permissions.  I've tried to to a chgrp on the
to be "apache", but it didn't take, on the symlink.

Any ideas on what's going on here?  I can still serve my normal .html
and any non-perl cgi-bin files just fine, and the same for other sites
that I host that have .html, javascript, and cgi-bin.  I was looking
through the archives for the mailing list on MarkMail and came across
something similar,

and in that case the submitter filed a bug report

Thanks in advance for any advice on this subject.


View raw message