httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt" <apacheuser...@wilber.pointclark.net>
Subject [users@httpd] mod_fastcgi is ignoring -init-start-delay ??
Date Wed, 01 Jul 2009 13:10:54 GMT
I have this line in my /etc/httpd/conf/httpd.conf file:
Include conf.d/*.conf


and my fast cgi configuration looks like this:
[root@server ~]# cat /etc/httpd/conf.d/mod_fastcgi.conf
ScriptAlias /fcgi-bin "/var/www/fcgi-bin/"

# FastCGI
# If the module hasn't been loaded yet, deny access to the directory
<IfModule !mod_fastcgi.c>
        <Directory "/var/www/fcgi-bin">
        AllowOverride None
        Options None
        Order allow,deny
        Deny from all
        </Directory>
</IfModule>

LoadModule fastcgi_module modules/mod_fastcgi.so

<IfModule mod_fastcgi.c>
FastCgiIpcDir /etc/httpd/fastcgi

        <Directory "/var/www/fcgi-bin">
        AllowOverride None
        Options +ExecCGI +FollowSymLinks +Includes -Indexes
        SetHandler fastcgi-script
        AddHandler fastcgi-script .fcg .fcgi .fpl
        Order allow,deny
        Allow from all
        </Directory>

# Start up the following static FastCGI applications.
# By default, the Process Manager will start one instance of the application with the default
configuration specified (in
parentheses) below.
# Should a static application instance die for any reason mod_fastcgi will spawn another to
replace it and log the event (at the
warn LogLevel).
#Include conf.d/fastcgi.static
FastCgiServer /var/www/fcgi-bin/someapp.fcgi -init-start-delay 5
FastCgiServer /var/www/fcgi-bin/anotherapp.fcgi -init-start-delay 10
FastCgiServer /var/www/fcgi-bin/newapp.fcgi -init-start-delay 20
FastCgiServer /var/www/fcgi-bin/otherapp.fcgi -init-start-delay 30
FastCgiServer /var/www/fcgi-bin/myspecialapp.fcgi -init-start-delay 60
</IfModule>


When I restart httpd:
[root@server ~]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
[root@server ~]#


Why does /var/log/httpd/error_log look like this:
[Wed Jul 01 18:19:48 2009] [notice] FastCGI: process manager initialized (pid 6650)
[Wed Jul 01 18:19:48 2009] [warn] FastCGI: server "/var/www/fcgi-bin/myspecialapp.fcgi" started
(pid 6651)
[Wed Jul 01 18:19:48 2009] [warn] FastCGI: server "/var/www/fcgi-bin/otherapp.fcgi" started
(pid 6652)
[Wed Jul 01 18:19:48 2009] [warn] FastCGI: server "/var/www/fcgi-bin/newapp.fcgi" started
(pid 6653)
[Wed Jul 01 18:19:48 2009] [warn] FastCGI: server "/var/www/fcgi-bin/anotherapp.fcgi" started
(pid 6654)
[Wed Jul 01 18:19:48 2009] [warn] FastCGI: server "/var/www/fcgi-bin/someapp.fcgi" started
(pid 6655)


***** How come all these static FastCGI applications are all starting together at the same
time? How come they aren't scatter
started? I'd expect to see either:
[Wed Jul 01 18:19:48 2009] [notice] FastCGI: process manager initialized (pid 6650)
[Wed Jul 01 18:19:53 2009] [warn] FastCGI: server "/var/www/fcgi-bin/someapp.fcgi" started
(pid 6651)
[Wed Jul 01 18:19:58 2009] [warn] FastCGI: server "/var/www/fcgi-bin/anotherapp.fcgi" started
(pid 6652)
[Wed Jul 01 18:20:08 2009] [warn] FastCGI: server "/var/www/fcgi-bin/newapp.fcgi" started
(pid 6653)
[Wed Jul 01 18:20:18 2009] [warn] FastCGI: server "/var/www/fcgi-bin/otherapp.fcgi" started
(pid 6654)
[Wed Jul 01 18:20:48 2009] [warn] FastCGI: server "/var/www/fcgi-bin/myspecialapp.fcgi" started
(pid 6655)
OR
[Wed Jul 01 18:19:48 2009] [notice] FastCGI: process manager initialized (pid 6650)
[Wed Jul 01 18:19:53 2009] [warn] FastCGI: server "/var/www/fcgi-bin/someapp.fcgi" started
(pid 6651)
[Wed Jul 01 18:20:03 2009] [warn] FastCGI: server "/var/www/fcgi-bin/anotherapp.fcgi" started
(pid 6652)
[Wed Jul 01 18:20:23 2009] [warn] FastCGI: server "/var/www/fcgi-bin/newapp.fcgi" started
(pid 6653)
[Wed Jul 01 18:20:53 2009] [warn] FastCGI: server "/var/www/fcgi-bin/otherapp.fcgi" started
(pid 6654)
[Wed Jul 01 18:21:53 2009] [warn] FastCGI: server "/var/www/fcgi-bin/myspecialapp.fcgi" started
(pid 6655)



I am using apache installed from rpm:
[root@server ~]# rpm --query httpd-2.2.3-22.el5.centos.1.x86_64
httpd-2.2.3-22.el5.centos.1
[root@server ~]#


I installed mod_fastcgi from source:
 3790  tar xvfz mod_fastcgi-2.4.6.tar.gz
 3791  cd mod_fastcgi-2.4.6
 3792  cp Makefile.AP2 Makefile
 3793  nano -w Makefile
 3794  echo "top_dir      = /usr/lib64/httpd"
 3795  make
 3796  make check
 3797  make install
 3798  cd ..
 3799  ldconfig -v
 3800  ldconfig -v
 3801  service httpd restart


I'm using this distro:
[root@server ~]# cat /etc/redhat-release
CentOS release 5.3 (Final)
[root@server ~]#


Any help would be appreciated.

Thanks.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message