httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Montgomery <chrisnc...@gmail.com>
Subject Re: [users@httpd] Setting Up Virtual Host Help Needed on WinXP
Date Thu, 03 Jun 2010 22:26:35 GMT
Well, not quite there yet. As I said in my other msg, I was able to 
successfully hit http://myapps/index.html and get my dummy page to come 
up after adding "myapps" to my hosts file and adding a Directory entry 
in httpd.conf (I was getting a Access Forbidden before that):

<Directory "D:/webapps/myapps/">
     Order allow,deny
     Allow from all
</Directory>

Now, when I attempt to reach down into subdirectories, I am encountering 
a 404 Not Found error. For example, I have a test folder under 
D:/webapps/myapps/ but when I point my browser to 
"http://myapps/test/index.html" it throws the 404 error.

There must be some directive in the httpd.conf file to allow sub-folders 
to be visible, right?

Thanks.

Jorge Schrauwen said the following on 6/3/2010 4:28 PM:
> Hi,
>
> If you add a new virtualhost and give it a hostname (in your case
> "myapps") you're computer must be able to resolve the name to an IP.
> Most browser will append .com and prepend www. if they can't find one.
>
> So you're assumption of needing to add and entry to your hosts file is
> correct.

-- 
Best regards,

Chris Montgomery

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message