httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] mod_disk_cache causing corrupted output on server side includes?
Date Thu, 10 Jun 2010 23:25:13 GMT
On 6/10/2010 4:00 PM, Geoff Millikan wrote:
>>> Just in case your filesystem doesn't support them, have you tried
>>> disabling sendfile and mmap?
>>
>> Since all our files are being read directly off the drive 
>> (we're not using a NFS or CIFS mount) this shouldn't 
>> be an issue (at least on RedHat Enterprise
>> Linux).  But we'll give it a shot and report back.
> 
> Nope, that didn't help.  Within 2 hours the *.shtml web pages have binary
> data where the server side includes should be.  The cache worked great for
> the first 90 minutes or so.

Interesting... what other modules did you load?  Looking for possible sources
of memory corruption.

The uncached results to the client, they are ok?  E.g. is the cache polluted
on the way in, or on the way out?  Simulated load would help determine this.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message