httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sunanda Kundu <skund...@yahoo.com>
Subject [users@httpd] Apache2.2.16 LDAP authentication error
Date Sun, 08 Aug 2010 20:22:21 GMT
Hi,

I am running Apache2.2.16 on a Solaris10 server. I am not using SSL. The part of my httpd.conf
file is:

LoadModule rewrite_module modules/mod_rewrite.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule ldap_module modules/mod_ldap.so

    <Directory "/usr2/apache2.2.16/testdir">
        AuthType Basic
        AuthBasicProvider ldap
        AuthName "Directory Users"
        #AuthUserFile /dev/null
        AuthLDAPURL ldap://xxx.xxx.com:389/ou=People,ou=intranet,dc=xxxx,dc=com?uid?sub?(objectClass=*)
        AuthzLDAPAuthoritative Off
        #Satisfy Any
        Require valid-user
    </Directory>

The website comes up. But access to http://xxx.xom/testdir prompts for LDAP authentication
but returns 500 Internal Server Error on the browser after typing in login/password (no matter
login/password is correct or not). The server error logs have no further information.I used
openldap-2.4.22-sol10-sparc-local package.

I am trying to upgrade from Apache 1.3.28 to Apache 2.2.16. The LDAP
authentication works on the same server in Apache 1.3.28.
Could anyone please correct me if I am making any mistake in the syntax above?


      

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message