httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [users@httpd] Re : [users@httpd] proxy_loadbalancer and failover
Date Thu, 19 Aug 2010 15:58:40 GMT
On 19.08.2010 16:44, michael bienstein wrote:
> Hi,
>
> Thanks for the help. I have a IIS listening on port 80 and nothing on
> port 81.
>
> Version is Apache/2.2.16 (Win32)
> Server Built: Jul 30 2010 16:15:37
>
> Here's the changes I've made to the httpd.config from the default install:
> httpd.config
>
> Listen 8081
>
> #Used in other tests (sticky session cookie writing)
> LoadModule headers_module modules/mod_headers.so
> #Used for this test
> LoadModule proxy_module modules/mod_proxy.so
> LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
> LoadModule proxy_connect_module modules/mod_proxy_connect.so

You likely don't need to activate mod_proxy_connect. At least you don't 
allow the CONNECT method in the config below.

> LoadModule proxy_http_module modules/mod_proxy_http.so
> #Used in other tests (sticky session tests)
> LoadModule setenvif_module modules/mod_setenvif.so
> #For seeing the scoreboard
> LoadModule status_module modules/mod_status.so
>
> ProxyRequests Off
> <Proxy balancer://mycluster>
> BalancerMember http://127.0.0.1:80 loadfactor=10
> BalancerMember http://127.0.0.1:81 loadfactor=10
> </Proxy>
> ProxyPassMatch (?i)^/qlikview(.*) balancer://mycluster/qlikview$1
> ProxyPassMatch (?i)^/qvajaxzfc/(.*) balancer://mycluster/qvajaxzfc/$1
> ProxyPassMatch (?i)^/qvprint/(.*) balancer://mycluster/qvprint/$1
> ProxyPassReverse /qlikview balancer://mycluster/qlikview
> ProxyPassReverse /qvajaxzfc/ balancer://mycluster/qvajaxzfc/
> ProxyPassReverse /qvprint/ balancer://mycluster/qvprint/
> <Location /balancer-manager>
> SetHandler balancer-manager
> </Location>

Looks OK as a basic configuration.

If the port 81 doesn't listen, then the request should fail earlier than 
the error message you showed. Maybe it does fail over to port 80 and we 
get the error there.

Could you please increase your LogLevel to "debug" and provide the error 
log snippet?

Regards,

Rainer

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message