httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kate Yoak <k...@yoak.com>
Subject [users@httpd] ProxyRemote fails silently
Date Fri, 06 Aug 2010 04:44:48 GMT
I am attempting to do something extremely simple with mod_proxy and am  
at a loss.

ProxyRequests On
ProxyRemote http://dev.foo.com/  http://foo.com:42001

The result is - these statements are ignored. If I proceed with normal  
server configuration - I'll get the default VirtualHost. If I remove  
all VirtualHost configuration - I get 404. The web server on the other  
port is verified to work correctly.

If I add

<Proxy *>
     Order deny,allow
     Deny from all  #I do not get a proxy error, same 404
</Proxy>

Allow from all does not make any difference either.

Apache 2.2.3

mod_proxy and all its cousins are enabled:

LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_connect_module modules/mod_proxy_connect.s


What am I doing wrong?



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message