httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Whitson <steven.whit...@gmail.com>
Subject Re: [users@httpd] Can't load driver file apr_dbd_mysql.so
Date Wed, 01 Sep 2010 22:03:27 GMT
  Still no luck... I added the path /usr/sfw/lib to the envvars 
LD_LIBRARY_PATH, I had also tried adding to my path before launching.

I did notice that this version of mysql is 4.0.  I want to be using 5.0 
but the libmysqlclient_r library isn't available in this installation.  
As I had mentioned, I do have an apache 2.2.9 working using the mysql 
4.0 version client.

Anyway, I'm downloading a 5.0 version of mysql to see if it will work.  
Apparently 5.1 isn't known, since in the config.log for apr_util (I'm 
sticking to just building this piece util I get it right) it had problems.

Thanks much,
     -Steve


On 9/1/2010 4:04 PM, Nick Kew wrote:
> On Wed, 01 Sep 2010 14:57:37 -0500
> Steve Whitson<steven.whitson@gmail.com>  wrote:
>
>>    ldd informs me that libmysqlclient is linked in at the following path:
>>       /usr/sfw/lib/libmysqlclient_r.so.12
>>
>> I've never tried loading the library explicitly,  I see what that
>> does.... odd that the 'working' apache installation has the same module
>> with the same dependencies (libmysqlclient) and works.
> It could be that your apache installation doesn't know about /usr/sfw.
> If so, adding /usr/sfw/lib to LD_LIBRARY_PATH in apache's bin/envvars
> may be the fix you want (though explicit loading should also work).
>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message