httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Volf <fr...@deze.org>
Subject [users@httpd] FreeBSD IPv6 only jail with Apache
Date Sat, 15 Jan 2011 14:58:15 GMT
Hi,

To learn more about IPv6 I have setup an IPv6 only jail in FreeBSD 8-STABLE.  
The IP address assigned to the jail is part of a public IPv6 prefix that I obtained
from my ISP.

The jail is started with 'ip4=disable' as a startup option to the jail
command.

The jail works fine. I can ping(6), traceroute(6), resolve
IP addresses and a DNS resolver that I reach on its IPv6 address.

Now, I trying to use apache22 to setup a web-server (once again only
reachable via IPv6). And here the problem starts. I just can't get the
thing to start, it core-dumps immediately:six# /usr/local/etc/rc.d/apache22 start

    Performing sanity check on apache22 configuration:
    [Sat Jan 15 15:27:54 2011] [crit] [Sat Jan 15 15:27:54 2011] file
    config.c, line 1982, assertion "rv == APR_SUCCESS" failed
    Abort trap (core dumped)
    Starting apache22.
    [Sat Jan 15 15:27:54 2011] [crit] [Sat Jan 15 15:27:54 2011] file
    config.c, line 1982, assertion "rv == APR_SUCCESS" failed
    Abort trap (core dumped)
    /usr/local/etc/rc.d/apache22: WARNING: failed to start apache22

The apache version is apache-2.2.17_1 from the FreeBSD port collection using all the default
options.

The httpd.conf file is pretty straightforward. Unfortunately, I get a mail bounce 

	552 spam score (5.3) exceeded threshold (in reply to end of DATA command)

if I include it in this email, so I only post the changed lines compared to the distrubtion
httpd.conf:

    Listen [2001:980:1312:6::1]:80
    ServerName six.ipv6.deze.org:80
    LoadModule php5_module libexec/apache22/libphp5.so
    DirectoryIndex index.html index.php
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

The hostname of the jail is resolvable (forward and reverse) via DNS and
is also in /etc/hosts. But the hostname has only an AAAA record, but no
A record in DNS.

I tried to debug the apache and apr code, but that is not every easy either.

So, my final hope is this list. Does anybody have a solution, or a clue
how to proceed with debugging this problem?

Kind regards,

Frank



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message