httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Kew <n...@webthing.com>
Subject Re: [users@httpd] Missing static contents on 1st page hit with Apache+mod_jk
Date Thu, 03 Feb 2011 23:39:10 GMT
On Mon, 31 Jan 2011 17:40:08 -0800 (PST)
Setya <jsetya@gmail.com> wrote:

> 
> Hi,
> 
> From the logs, on 1st page hit requests are appended with jsessionid &
> jsessionidversion, while the 2nd hit are not, maybe this is what causes the
> static contents are not rendered on 1st page hit ? Could somebody explain
> about this ?

The jsession stuff is what your browser requested, and presumably
come from your application on the glassfish.

The server has returned a bunch of redirects (302s).  This may
be intentional.  If so, you need to figure out where the redirects
are going (your browser can tell you that), and fix it.

The tutorial at http://www.apachetutor.org/admin/reverseproxies
may help to understand why it's not working, although not all
the techniques described there are applicable with mod_jk.

The fact that you're getting session stuff and redirects
associated with static contents probably indicates a
poorly-implemented application running on the glassfish.


-- 
Nick Kew

Available for work, contract or permanent.
http://www.webthing.com/~nick/cv.html

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message