httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <>
Subject Re: [users@httpd] Apache taking (exactly) 30 seconds to serve static images
Date Mon, 16 Jul 2012 19:06:20 GMT

---- Nick Kew <> wrote: 
> On Mon, 16 Jul 2012 10:47:54 -0400
> <> wrote:
> > Has anyone encountered something like this.  What timeouts might be set to 30 seconds
in Apache that might be causing this kind of behavior?
> Check your keepalive.
> If your browser, or some agent on the network, is getting its knickers
> in a twist about making lots of requests, it might be waiting for one
> keepalive connection to close before opening another through which
> it's scheduled to fetch those images.
> If you have any kind of rate-limiting or DoS-protection module in Apache,
> that could also be delaying a connection if the client is trying to
> open more than your server defences permit.
> -- 
> Nick Kew

Hi Nick,

This is a really strange one.  The page is an HTML login page, with not much too it, and has
some links for background images (maybe 4-5 of them).  Not much to it.  The images aren't
huge either, max ~70KB.

- Apache is 2.2.22, which we built, on Redhat 64bit.
- The problem only happens if we enable SSL on Apache, either 1-way or 2-way SSL have same
- Sometimes the page comes up.  Sometimes it comes up partially, and then sits there for awhile.
 Firefox Firebug is showing "aborted" (in red) for the image GETs in the latter case.
- There are no firewalls or DOS-type software.  I'm going directly from the browser (Firefox
and IE) to Apache.

Thus far what we've tried:

- Changed SSLRandomKey to point to /dev/urandom ==> no change in problem

- Tried adding to <VirtualHost> in ssl.conf:

KeepAlive off
KeepAliveTimeout 2

==> no change in problem.

- Apache error_log doesn't show anything weird/errors.

- As I mentioned, the problem can happen with either Firefox or IE

- Apache is built with MPM pre-fork, here's the "httpd -V":

Server version: Apache/2.2.22 (Unix)
Server built:   Jun 20 2012 12:11:29
Server's Module Magic Number: 20051115:30
Server loaded:  APR 1.4.5, APR-Util 1.4.1
Compiled using: APR 1.4.5, APR-Util 1.4.1
Architecture:   64-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D HTTPD_ROOT="/apps/oracle/apache"
 -D SUEXEC_BIN="/apps/oracle/apache/bin/suexec"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

And, here's the weirdest part:  I *think* that if I run Apache in single-process mode (-k
start -X), the problem doesn't happen.  I've tried a bunch of tests when Apache is in single-process
mode, and haven't been able to get the problem yet.  Assuming that I continue to not see the
problem when in single-process mode, does that point to something as the problem?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message