httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Baker" <>
Subject [users@httpd] Apache on Windows NFS Mount
Date Fri, 28 Sep 2012 19:42:20 GMT
I'm trying to get apache on windows 2008 R2 to work with an NFS mount as
the document root. I have done the following:


- Setup Services for Network File System

- Ran the following commands (again on windows): mount
\\\test_htdocs <file:///\\\test_htdocs>  X:

- I can open my computer and browse the X: drive, create files.

- I open up httpd.conf and change my configuration as such:

        DocumentRoot "X:/new"

        <Directory "X:/new">

- I fire up the apache service and it immediately fails and I have the
following errors in the event log:

        The Apache service named  reported the following error:

        >>> AH00526: Syntax error on line 243 of
C:/Apache/conf/httpd.conf:     .


        The Apache service named  reported the following error:

        >>> DocumentRoot must be a directory     .


I'm running Apache/2.4.3 (Win64) if that matters. I'm running apache as
an active directory account (ourdomain\apache) and the same account with
the same username and password exists on the destination NFS server)


I've tried changing the directory to X:/new, X:/new/, X:\new, X:\new\
none of the combinations seems to work.


I have the same configuration working on a linux box so I don't think
the issue is with the NFS server but rather something to do with the
windows/apache box.  Before you suggest that I scrap NFS and use SMB -
I've already tried that. SMB works but performance is dreadful (20+
second load times).


I've also configured EnableMMAP off and EnableSendfile off which I
believe is suggested for network file systems. That doesn't help (either
with SMB or NFS). Can anyone help me understand why this is failing?





View raw message