httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Arnold <carn...@electrichendrix.com>
Subject [users@httpd] Proxy Config Problem
Date Fri, 08 Feb 2013 21:58:27 GMT
I am trying to proxy a connection from ifolder client to our ifolder server. Here are the proxypass
statements:

	ProxyPass /ifolder https://192.168.123.4/ifolder
	ProxyPassReverse /ifolder https://192.168.123.4/ifolder

With just those statements, i get these errors in the apache proxy server error.log:

[Thu Feb 07 09:23:24 2013] [error] [client xx.xx.xx.xx] File does not exist: /srv/www/htdocs/simias10
[Thu Feb 07 09:25:38 2013] [error] [client xx.xx.xx.xx] File does not exist: /srv/www/htdocs/simias10
[Thu Feb 07 09:43:40 2013] [error] [client xx.xx.xx.xx] File does not exist: /srv/www/htdocs/simias10
[Thu Feb 07 09:44:13 2013] [error] [client xx.xx.xx.xx] File does not exist: /srv/www/htdocs/simias10
        
So, i enter these proxypass statements below the above statements:

        ProxyPass /simias10/ https://192.168.123.4/simias10/
	ProxyPassReverse /simias10/ https://192.168.123.4/simias10/

This gives me this in the apache proxy access log (nothing in the error log):

[08/Feb/2013:04:12:51 -0500] "POST /simias10/DomainService.asmx HTTP/1.1" 200 404
[08/Feb/2013:04:12:55 -0500] "POST /simias10/Login.ashx HTTP/1.1" 401 -
[08/Feb/2013:04:12:55 -0500] "POST /simias10/Login.ashx HTTP/1.1" 200 -
[08/Feb/2013:04:12:56 -0500] "POST /simias10/DomainService.asmx HTTP/1.1" 200 950
[08/Feb/2013:04:13:12 -0500] "POST /simias10/DomainService.asmx HTTP/1.1" 200 404
[08/Feb/2013:04:13:15 -0500] "POST /simias10/Login.ashx HTTP/1.1" 200 -
[08/Feb/2013:04:13:15 -0500] "POST /simias10/DomainService.asmx HTTP/1.1" 200 950

notice the 200's and then 404's.

I have tried both,

        ProxyPass /simias10/ https://192.168.123.4/simias10/
	ProxyPassReverse /simias10/ https://192.168.123.4/simias10/
and
        ProxyPass /simias10 https://192.168.123.4/simias10
	ProxyPassReverse /simias10 https://192.168.123.4/simias10
notice the trailing "/" in both statements.

Here is the network setup for that which is in question:
---->internet-->sonicwall router with 1 public ip and doing nat/pat-->apache proxy
server sends 80/443 traffic to-->ifolder/mail server.

Is there something extra i need to include in the proxypass statements to make this work?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message