httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony J. Biacco" <>
Subject RE: [users@httpd] Apache on CentOS 6 -- lots of reading requests
Date Thu, 10 Oct 2013 13:03:40 GMT
I'd like to resurrect the below thread as I'm seeing this on my new CentOS 6.4 (kernel 2.6.32-358.18.1.el6.x86_64)/Apache
2.2.24 (compiled) servers.
Never had the problem on my CentOS 5 ones.
I can't lower my timeout in apache, as I have dynamic backend content needing a 120+s timeout.
Haven't found anything else out there to solve this problem and seems to me like it'd be a

Any help is appreciated.


From: linuxsupport [] 
Sent: Saturday, April 06, 2013 10:21 AM
Subject: Re: [users@httpd] Apache on CentOS 6 -- lots of reading requests

I tried setting up TimeOut to 10 seconds, even then there are huge reading requests.
At a time, out of 44 total concurrent requests 34 were in "reading" state.

On Sat, Apr 6, 2013 at 1:54 PM, Marcin Wanat <> wrote:

i had the same problem after migrating from Centos 5. After a few days of testing, reinstallations
between Centos 5 and 6 and recompiling different kernels i found it.
It is connected with Preconnection function in new browsers (
and starts showing in kernel 2.6.32.
Probably previous kernels including are handling such requests in different way
and they doesn't come to Apache until http header is sent. 
I do not know what exactly has been changed between and 2.6.32 (changelog is over
8MB long) but it seems to be ok that Reading Request connections appear in server status. 
If you have too many of them you can decrease Timeout in httpd config.

Marcin Wanat

2013/4/6 linuxsupport <>
I am facing a problem with Apache on CentOS 6
Apache 2.2.19 is complied from source.
I see so many reading requests in Apache status page, as per my previous experience this "reading
request" issue mainly comes when any of the internet route having any problem and request
takes time to completely reach to Apache, but this time there is no network issue.
I have ran same setup on CentOS 5 it works well, but on CentOS 6 it show 60%+ reading requests,
web site has 20-25 requests per second that becomes 80+
I also tried to upgrade Apache to 2.2.24 but it is same on new version as well.
Anyone else has experienced this issue?

View raw message