httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ammar Hassan <amr...@live.jp>
Subject RE: [users@httpd] Apache Virtual Host Config issue
Date Sun, 13 Oct 2013 23:51:52 GMT
Please help me sort this out. What is it that I am doing wrong here.



----------------------------------------
> From: amrhsn@live.jp
> To: users@httpd.apache.org
> Date: Thu, 10 Oct 2013 12:36:29 +0900
> Subject: RE: [users@httpd] Apache Virtual Host Config issue
>
> Yehuda,
>
> Actually there were two entries as you rightly pointed out.
>
> TCP    0.0.0.0:8080           0.0.0.0:0              LISTENING
> TCP    [::]:8080              [::]:0                 LISTENING
>
>
> The one other Listen directive I have in my httpd.conf is
>
> Listen 8080
>
> Then in vhosts I have
>
> Listen 123.45.6.789:8080
>
> The subdomain is resolving to the IP (the one I mentioned is just an example) the ping
is fine, When I browse the website with localhost:8080 or from LAN ip 192.168.0.1:8080 the
site works perfect.
>
>
> As a test, I mapped the subdomain on a dummy IIS website, when I browsed it, it worked
fine.
> When I put 8080 at the end of the domain it says server timed out.
>
> -Ammar
>
> ________________________________
>> From: yehuda@ymkatz.net
>> Date: Wed, 9 Oct 2013 23:10:18 -0400
>> To: users@httpd.apache.org
>> Subject: Re: [users@httpd] Apache Virtual Host Config issue
>>
>> On Wed, Oct 9, 2013 at 11:03 PM, Ammar Hassan
>> <amrhsn@live.jp<mailto:amrhsn@live.jp>> wrote:
>> Thank you for a detailed reply. I have gone through the things you
>> asked me to check. There was an entry in netstat -an like this:
>>
>> TCP [::]:8080 [::]:0 LISTENING
>>
>> Which suggests that Apache is running. So now what I did was, I tried
>> to add a Listen directive to the IPAddress the subdomain was resolving
>> to.
>>
>> If that was the only line that matched, apache is only listening on IPv6.
>>
>> Listen 123.45.6.789:8080
>> Do you have other listen lines in your configuration?
>> It might help to enable the server info module and see if there are any
>> listed in its output.
>>
>> I also added a virual host entry explicitly for this IP
>> <VirtualHost 123.45.6.789:8080>
>> ServerName subdomain.example.com<http://subdomain.example.com>
>> </VirtualHost>
>> You should not add a virtual host unless you want it to have different
>> content or configuration.
>> Otherwise it will make this harder.
>>
>> When I restarted Apache it failed with the following error:
>> "Context of the address was (OS 10049) request is invalid. : AH00072:
>> make_sock: could not bind to address 123.45.6.789:8080"
>>
>> Are you sure it points to that address? That is not a valid IP address
>> which would explain why apache can't bind to it.
>>
>> - Y
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 		 	   		  
Mime
View raw message