httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Curchod <>
Subject RE: [users@httpd] Permission Still Denied with Moodle
Date Sun, 13 Oct 2013 12:17:43 GMT
Hello everyone,
Hope you're all having a good weekend.  The good news here is that I've solved the localhost
problem.  The moodle config file, when set with this value "$CFG->wwwroot = 'localhostmoodle';"
and then going to 'http://localhost/moodle' works and is fully functional. However, changing
that value to '$CFG->wwwroot   = 'http://*my*.*ip*.*goes*.*here*:80/moodle';" and going
to http://*my*.*ip*.*goes*.*here*:80/moodle doesn't.  Google Chrome removes the :80 for some
reason from the address bar (Firefox doesn't) and it takes almost a minute to come back with
the "Oops!" message, as if the server is not on.  But if I change the config.php file for
moodle to respond to localhost, it responds right away with the index.php.  Another test file
works on localhost, but again is not served from the web.
The full httpd error log for the problem can be seen here:
first error from which is:[autoindex:error] [pid 4396] [client] AH01276: Cannot
serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and
server-generated directory index forbidden by Options directive, referer: http://localhost/moodle/login/index.php
Why is it then forbidden to serve something to the web that is OK for localhost?  Is the router
a problem?  Is Tomcat listening on Port 8080  on a different box causing a problem with this
box listening on port 80?  The Apache config file is set to listen to 80.  I tried some other
values for this, changing them in the router and the config file and none worked.
The Linksys WRT54C router using Automatic Configuration DHCP is set as follows:Port RangeApplication
        Start 	End	     Protocol	IP Address	        EnableApache httpd   	80 to	80	     Both	Check  	Apache Tomcat 	8080 to   8080    Both       Check 
(Both means TCP and UDP)
Taking moodle out of the picture and running strace on cuases
the same error.  So it's not a Moodle problem.  Here are some more details I may or may not
have posted in earlier e-mails:
netstat -ln | grep 80tcp6       0      0 :::80                   :::*                    LISTEN
    unix  2      [ ACC ]     STREAM     LISTENING     18068    @/tmp/.ICE-unix/1205unix  2
     [ ACC ]     STREAM     LISTENING     18069    /tmp/.ICE-unix/1205
httpd -SVirtualHost configuration:ServerRoot: "/etc/httpd"Main DocumentRoot: "/var/www/html"Main
ErrorLog: "/etc/httpd/logs/error_log"Mutex proxy: using_defaultsMutex authn-socache: using_defaultsMutex
default: dir="/run/httpd/" mechanism=default Mutex mpm-accept: using_defaultsMutex authdigest-opaque:
using_defaultsMutex proxy-balancer-shm: using_defaultsMutex rewrite-map: using_defaultsMutex
authdigest-client: using_defaultsPidFile: "/run/httpd/"Define: DUMP_VHOSTSDefine:
DUMP_RUN_CFGUser: name="apache" id=48Group: name="apache" id=48

> Date: Thu, 10 Oct 2013 19:11:17 -0400
> To:
> From:
> Subject: RE: [users@httpd] Permission Still Denied with Moodle
> At 10:17 AM 10/10/2013 +0000, you wrote:
> [snip]
> >/sbin/ifconfig
> >em1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
> >         inet  netmask  broadcast
>                ^^^^^^^^^^^^^^
> Have you got a router set up for DHCP?
> [snip]
> >Something funny is going on with the ip address however.  When I go to 
> >localhost, like I said before, it prints this message:  "Incorrect access 
> >detected, this server may be accessed only through 
> >"http://*.*.*.30:80/moodle" address, sorry.
> Best - Paul
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:
View raw message