httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Curchod <>
Subject RE: [users@httpd] Permission Still Denied with Moodle
Date Sun, 13 Oct 2013 14:10:26 GMT
Thanks for you replies.  I will set the timezone as you suggest.  I also disabled mod_autoindex
by commenting out the "Options Indexes FollowSymLinks" line in the httpd.conf file.  However,
it doesn't help the situation.
You may be right about the IP4 & IPv6 idea.  I have a strange network card that has two
ports with cables leading to the motherboard, the likes of which I've never used before. 
I ran nestat on the two boxes behind my router and got this.On my other box running Fedoa
11, the netstat command says TCP   	   0      0   :::8080	:::*	LISTEN	    5418:javaOn the
Fedora 19 box:tcp6       0      0   :::80     :::*    LISTEN      11739/httpd     
Does that tcp6 mean IPv6?  I'm not sure.  Then I read this on Apache about IPv4 and IPv6:
If you want Apache to handle IPv4 connections only, regardless of what your platform and APR
will support, specify an IPv4 address on all Listen directives, as in the following examples:Listen your platform supports it and you want Apache to handle IPv4
and IPv6 connections on separate sockets (i.e., to disable IPv4-mapped addresses), specify
the --disable-v4-mapped configure option.(
SO I tried:#Listen 80Listen
But got this error and Apache failed to start.  Active: failed (Result: exit-code) since Sun
2013-10-13 22:42:53 KST; 1min 4s ago  Process: 12488 ExecStop=/usr/sbin/httpd $OPTIONS -k
graceful-stop (code=exited, status=0/SUCCESS)  Process: 3893 ExecReload=/usr/sbin/httpd $OPTIONS
-k graceful (code=exited, status=0/SUCCESS)  Process: 12487 ExecStart=/usr/sbin/httpd $OPTIONS
-DFOREGROUND (code=exited, status=1/FAILURE)  Status: "Total requests: 1; Current requests/sec:
0; Current traffic:   0 B/sec"Oct 13 22:42:53 localhost.localdomain httpd[12487]: (99)Cannot
assign requested address: AH00072: make_sock: could not bind to address
I'm not sure how to use that configure option '--disable-v4-mapped'.  Where does that go?
 It seems like a start up script flag, but I use systemctl to start httpd.  I couldn't find
an example of how to use that.  Will that add IPv4 address listening?
Timothy Curchod.
Date: Sun, 13 Oct 2013 09:47:30 -0400
Subject: Re: [users@httpd] Permission Still Denied with Moodle

Now that I am at the computer, a more in-depth reply.
On Sun, Oct 13, 2013 at 8:17 AM, Timothy Curchod <> wrote:

However, changing that value to '$CFG->wwwroot   = 'http://*my*.*ip*.*goes*.*here*:80/moodle';"
and going to http://*my*.*ip*.*goes*.*here*:80/moodle doesn't.  Google Chrome removes the
:80 for some reason from the address bar (Firefox doesn't)

Because the :80 is redundant according to Chrome because 80 is the "well-known" port for http.

and it takes almost a minute to come back with the "Oops!" message, as if the server is not

That is because the request is not rejected or accepted, it just times out. 

The full httpd error log for the problem can be seen here:

The first error from which is:

[autoindex:error] [pid 4396] [client] AH01276: Cannot serve directory /var/www/html/:
No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index
forbidden by Options directive, referer: http://localhost/moodle/login/index.php

Server generated directory index is talking about mod_autoindex and for a production system,
it should be disabled unless you specifically need it.You need to see why the login page is
redirecting you to the wrong place. I imagine that after login, you should be redirected to
/moodle, not / as the error log indicated is happening.

Also, I recommend you set your timezone in php.ini as mentioned in the error log. It will
save you from some odd situations where date functions don't work properly.

Why is it then forbidden to serve something to the web that is OK for localhost?

The error log does not indicate that this is the case. To the contrary, every entry in the
log that references a client says the source is (a.k.a. localhost).

The Linksys WRT54C router using Automatic Configuration DHCP is set as follows:

Port RangeApplication	        Start 	End	     Protocol	IP Address	        Enable

Apache httpd   	80 to	80	     Both	Check  	

Apache Tomcat 	8080 to   8080    Both       Check  

(Both means TCP and UDP)

Can you take the linksys out of the picture by accessing from another computer
inside your network?

Taking moodle out of the picture and running strace on cuases
the same error.  So it's not a Moodle problem.

Since this thread has mentioned several different errors (permissions, DirectoryIndex, timeout)
which one are you referring to? 

netstat -ln | grep 80

tcp6       0      0 :::80                   :::*                    LISTEN     

unix  2      [ ACC ]     STREAM     LISTENING     18068    @/tmp/.ICE-unix/1205

unix  2      [ ACC ]     STREAM     LISTENING     18069    /tmp/.ICE-unix/1205

As I mentioned, your IPv4 address is not listed here...
- Y 		 	   		  
View raw message