httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Canfield <andycanfi...@yandex.com>
Subject Re: [users@httpd] localhost Forbidden
Date Mon, 05 May 2014 00:54:02 GMT
I think I've fixed it.

My /etc/apache2/apache2.conf still contains these lines as installed:
    <Directory />
            Options FollowSymLinks
            AllowOverride None
            Require all denied
    </Directory>

My /etc/apache2/sites-enabled/00_default.conf contains these lines:
    <VirtualHost *:80>
            DocumentRoot /www/default/Site
    </VirtualHost>
followed by these lines:
    <Directory /www/default/Site>
            AuthType None
            Require all granted
            Options FollowSymLinks
    </Directory>

My subsite http://localhost/pix contains these lines:
    Alias /pix /www/pix/Site
    <Directory /www/pix/Site>
            AuthType None
            Require all granted
            Options FollowSymLinks
    </Directory>
Note that there is no VirtualHost statement here, like there used to be
in my apache 2.2 configuration statements. In all my conf files there is
now only one <VirtualHost *:80> statement. Every one of my subsites has
those same six lines - Alias + Directory, with "pix" changed to whatever
the name of that subsite is.

It appears as though apache2 was getting very upset with having multiple
VirtualHost statements for the same virtual host. That worked OK in 2.2,
but not in 2.4. And there was no error when restarting apache, only when
accessing one of the sites. And the "403:Forbidden" seemed to arise
regardless of which sub-site I was trying to look at.

Thank you all; your help was invaluable.

Andy Canfield
- www.andycanfield.com


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message