httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Biggerstaff <pe...@biggerstaff.co.nz>
Subject [users@httpd] Virtual Hosts not working
Date Tue, 20 May 2014 01:39:39 GMT
Hi All,

I am tearing my hair out trying to get virtual hosts to work, but apache 
seems to be ignoring the /etc/apache2/sites-enabled config files.

I have been trying all morning to get it to work, and here is the 
current state:

IncludeOptional sites-enabled/*.conf is in the /etc/apache2/apache2.conf

in /etc/init.d/sites-available I have a file called virtualhosts with 
the following config:

# Ensure that Apache listens on port 80
Listen 80
<VirtualHost *:80>
     DocumentRoot /var/www/html
     ServerName biggerstaff.co.nz
</VirtualHost>

<VirtualHost *:80>
     DocumentRoot /var/www/html/mail/
     ServerName mail.biggerstaff.co.nz
</VirtualHost>

only mail.biggerstaff.co.nz has a DNS entry set up at this stage, so in 
theory if I go to http://mail.biggerstaff.co.nz I should go though to 
/var/www/html/mail/ right?

I have a symbolic link in /etc/init.d/sites-enabled/virtualhosts --> 
/etc/init.d/sites-available/virtualhosts

when I navigate to http://mail.biggerstaff.co.nz I end up at the file 
list in /var/www

There are no error logs etc.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message