httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@gmail.com>
Subject Re: [users] Building apr on win32
Date Thu, 12 Jun 2014 23:07:53 GMT
On Thu, Jun 12, 2014 at 5:42 PM, Christopher Schultz <
chris@christopherschultz.net> wrote:

> All,
>
> I'm hoping this is the right mailing list: the apr project seems to have
> a "dev" list but no user one. I'm happy to move if appropriate.
>

If you're just trying to build APR components, dev@apr.apache.org is more
appropriate.

If you're trying to build httpd + all the various support libraries, this
mailing list or a forum at http://www.apachelounge.com/ (not affiliated
with the ASF) is okay.


>
> I'm trying to build apr on win32 from the command-line and I'm running
> into some resistance. I'm using Visual Studio 12 on Windows 8.1. I have
> installed the "Windows SDK" as well to try to help, but it doesn't seem
> to have improved things.
>
> I'm following the instructions found here:
> http://apr.apache.org/compiling_win32.html
>
> I have downloaded the ZIP files for apr, apr-util, and apr-iconv and put
> them into the requisite directories.
>
> I've run VS's VC\bin\vcvars32.bat to get the build tools in the path,
> but I don't have a setenv.bat anywhere (suggested in the above
> instructions). When I get to the step where I run "msdev" (which
> basically /does the build/), I can't find the msdev program:
>
> C:\Users\Me\Desktop\apr-util>msdev aprutil.dsw /MAKE "apriconv - Win32
> Release"
> 'msdev' is not recognized as an internal or external command,
> operable program or batch file.
>
> I'm no win32 build expert, but I have quite a bit of experience building
> on *NIX systems. Can anyone help me get things going on Windows?
>
> Thanks,
> -chris
>
>


-- 
Born in Roswell... married an alien...
http://emptyhammock.com/
http://edjective.org/

Mime
View raw message