httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Johnson <ejohnso...@gmail.com>
Subject [users@httpd] proxying via ajp to backend wilfly server - AH01144: No protocol handler was valid for the URL /wildfly.css
Date Sat, 23 Aug 2014 02:31:59 GMT
Hi,

I just started testing reverse proxying to from apache 2.4 to a backend
wildfly 8.1 server using mod_proxy_ajp on centos 7, using this config:

(from conf.d/vhosts.conf):

<VirtualHost ...>
...
ProxyRequests Off

<Proxy balancer://cluster>
       BalancerMember ajp://127.0.0.1:8009
</Proxy>
ProxyPass / balancer://cluster stickysession=JSESSIONID
ProxyPassReverse / balancer://cluster
...
</VirtualHost>

(from conf.module.d/00-proxy.conf):

# This file configures all the proxy modules:

LoadModule proxy_module modules/mod_proxy.so
LoadModule lbmethod_bybusyness_module modules/mod_lbmethod_bybusyness.so
LoadModule lbmethod_byrequests_module modules/mod_lbmethod_byrequests.so
LoadModule lbmethod_bytraffic_module modules/mod_lbmethod_bytraffic.so
LoadModule lbmethod_heartbeat_module modules/mod_lbmethod_heartbeat.so
LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_express_module modules/mod_proxy_express.so
LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so
LoadModule proxy_fdpass_module modules/mod_proxy_fdpass.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_scgi_module modules/mod_proxy_scgi.so


When I request the / URL, the main document loads successfully, but the
 CSS and image resources fail to load with 500 internal server errors.
 From the apache ssl_error_logs:

[Fri Aug 22 22:10:50.657338 2014] [proxy:warn] [pid 12109] [client
67.247.10.110:36486] AH01144: No protocol handler was valid for the URL
/wildfly.css. If you are using a DSO version of mod_proxy, make sure the
proxy submodules are included in the configuration using LoadModule.,
referer:https://sandbox.dev.vosio.net/
[Fri Aug 22 22:10:50.785537 2014] [proxy:warn] [pid 12108] [client
67.247.10.110:43769] AH01144: No protocol handler was valid for the URL
/wildfly_logo.png. If you are using a DSO version of mod_proxy, make sure
the proxy submodules are included in the configuration using LoadModule.,
referer:https://sandbox.dev.vosio.net/
[Fri Aug 22 22:10:51.694137 2014] [proxy:warn] [pid 12107] [client
67.247.10.110:46474] AH01144: No protocol handler was valid for the URL
/jboss_community.png. If you are using a DSO version of mod_proxy, make
sure the proxy submodules are included in the configuration using
LoadModule., referer: https://sandbox.dev.vosio.net/
[Fri Aug 22 22:10:51.810280 2014] [proxy:warn] [pid 12109] [client
67.247.10.110:37843] AH01144: No protocol handler was valid for the URL
/favicon.ico. If you are using a DSO version of mod_proxy, make sure the
proxy submodules are included in the configuration using LoadModule.

>From what I can find from searching around, this is mostly due to people
not loading the correct proxy submodule, however the 00-proxy.conf config
is loading every proxy submodule there is.

is there anything anyone can see that I'm doing wrong?

thanks

-- 
-----
EJ

Mime
View raw message