httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <>
Subject Re: [users@httpd] what's the minimum version of openssl required by 2.2.29?
Date Thu, 05 Feb 2015 21:17:06 GMT
2015-02-05 18:42 GMT+01:00 Shane Witbeck <>:

> I recently upgraded apache from 2.2.27 to 2.2.29 and received the
> following error on startup:
> /usr/lib64/ no version information available
> After some searching, I determined that openssl needed to be upgraded.
> On CentOS 6.1 (yes, I know it¹s old):
> The previous version was: OpenSSL 1.0.0-fips 29 Mar 2010
> After upgrading via Œyum install openssl¹, the new version is: OpenSSL
> 1.0.1e-fips 11 Feb 2013
> This leads me to the question: What¹s the minimum version required by
> Apache 2.2.29?
> Thanks,
> Shane
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:


You don't specify if you upgraded through your distribution, or compiled
manually, in any case httpd will depend on openssl libraries to which it
was compiled, if none were specified it should be using the libraries
present in the system when you ran ./configure.

If you upgraded with a distribution upgrade it is hard to believe
dependencies are not met or there are library versions mismatches.

It looks to me as if you are installing different packages from different

So I believe it is better if you focus on meeting your distribution
dependencies, or if you compiled manually with an external openssl version
to add the /path/to/openssl/lib to your libpath or in envvars so httpd will
find the appropiate openssl libraries

*Daniel Ferradal*
IT Specialist


View raw message