On Feb 8, 2015, at 1:38 AM, YUSUI T <yusui.tomikawa@gmail.com> wrote:


The error.log says nothing.

Next, I exchanged <IfModule mod_rewrite.c> for the "Redirect". But it shows the following errors.

You probably could have left that entry in and just added the Redirect statement (not sure what flavor of OS you are using).

root@hostname:~# tail -n 6 /etc/apache2/mods-available/ssl.conf
<VirtualHost *:443>
        ServerName www.mydomain.com
        Redirect / https://www.mydomain.com/
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
root@hostname:~# service apache2 restart
 * Restarting web server apache2                                                Action 'start' failed.
The Apache error log may have more information.
                                                                         [fail]
 * The apache2 instance did not start within 20 seconds. Please read the log files to discover problems
root@hostname:~# tail -n 5 /var/log/apache2/error.log
[Sun Feb 08 06:12:22.767055 2015] [mpm_prefork:notice] [pid 5874] AH00169: caught SIGTERM, shutting down
[Sun Feb 08 06:12:23.818133 2015] [ssl:emerg] [pid 5950] AH02240: Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)
[Sun Feb 08 06:12:23.818204 2015] [ssl:emerg] [pid 5950] AH02312: Fatal error initialising mod_ssl, exiting.
[Sun Feb 08 06:14:23.209329 2015] [ssl:emerg] [pid 6028] AH02240: Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)
[Sun Feb 08 06:14:23.209419 2015] [ssl:emerg] [pid 6028] AH02312: Fatal error initialising mod_ssl, exiting.

Add Debug to your loglevel and try to restart. That should give a little more info.