httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Rumph <mike.ru...@oracle.com>
Subject Re: [users@httpd] sudo: apachectl: command not found
Date Tue, 31 Mar 2015 16:41:56 GMT
Hello Padmahas,

It looks like your two installations of Apache httpd 2.4 are conflicting 
with each other.
If I understand correctly, you first installed into /user and then into 
/usr/local/apache2.
Then you tried to remove the /user installation by deleting files manually.
(As you've seen, /user is not a good choice, because this is used for 
many other things as well.)
It would probably help to do a fresh installation.
But let's try a few things first.

When tried *" sudo /usr/local/apache2/bin/apachectl -k start "*
It gave " *httpd: Could not open configuration file 
/usr/conf/httpd.conf: No such file or directory ".*
You are probably wanting to use /usr/local/apache2/conf/httpd.conf instead.

What results do you get from *sudo /usr/local/apache2/bin/apachectl -V *  ?
Look inside */usr/local/apache2/bin/apachectl **
*What is the variable HTTPD set to?
You could try using *sudo /usr/local/apache2/bin/apachectl -k start 
-f**/usr/local/apache2/conf/httpd.conf
*to override the config file location.
*
*See the following links for further options on the apachectl or httpd 
commands:
- http://httpd.apache.org/docs/2.4/programs/apachectl.html
- http://httpd.apache.org/docs/2.4/programs/httpd.html

Thanks,

Mike Rumph

On 3/31/2015 3:36 AM, Padmahas Bn wrote:
> *If anyone finds this as a big question please let me know. I'll 
> precise my problem.
>
> Steps I followed:*
>
> I installed apr and apr-utils package in the path *"/usr"* using the 
> --prefix option.
>
> Both were installed successfully. Hence I installed apache 2.4 to the 
> same path ("/usr") using --prefix option while running *"./configure" .
>
> *
> *Later I came to know if prefix is not mentioned for apache2.4 
> installation, it will be installed inside /usr/local/apache2 by default.
>
> *
> Hence I again installed without specifying --prefix option which does 
> installed the apache2 into /usr/local/apache2.
>
> Now I cd to /usr/local/apache2/bin and run *sudo apachectl -k start 
> *and the apache server was started successfully. *Only later I came to 
> know the server is running from the /usr files  installed at first time.
>
> *
> Instead of having 2 installations I thought of removing the one 
> installed inside /usr and deleted all files manually and carefully 
> from all sub folders of /usr.
>
> *Now when I run the server from /usr/local/apache2 using "* *sudo 
> apachectl -k start " *it says *sudo: apachectl: command not found*
>
> So I supplied full path using *" sudo /usr/local/apache2/bin/apachectl 
> -k start "*
>
> But its giving " *httpd: Could not open configuration file 
> /usr/conf/httpd.conf: No such file or directory ".*
>
> Thank you.


Mime
View raw message