httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kenichi MASUDA <masu...@gmail.com>
Subject Re: [users@httpd] a lot of 502 error with using mod_proxy_http after upgrading tomcat
Date Mon, 14 Mar 2016 01:53:51 GMT
Hi,

Thank you for your reply.

> Did you test tomcat alone after the upgrade? Was it working as expected
or was it just showing weirdness? I would start from there :)
>
I didn't try tomcat only. But we use a lot of rewrite rules with httpd, so
that we cannot test easily...
Moreover, the errors sometimes occur, sometimes not...

>  My suggestion would be to check
https://tomcat.apache.org/tomcat-7.0-doc/changelog.html for changes between
the two versions that you
> mentioned to find anything that could have changed Tomcat's behavior.
>
I also think this would be a better way. We try to test and isolate the
problem to use various versions of tomcat.
Thank you.


2016-03-11 18:07 GMT+09:00 Luca Toscano <toscano.luca@gmail.com>:

> Hi!
>
> 2016-03-11 5:18 GMT+01:00 Kenichi MASUDA <masuken@gmail.com>:
>>
>>
>> httpd log say that "proxy: Error reading from remote server returned by"
>>
>
> This error is usually not httpd's fault, but something wrong thrown by the
> proxied host (that can be from TCP connection reset to HTTP
> malformed/garbage IIRC).
>
>
>> I downgraded tomcat to 7.0.39-1, so that these errors disappeared.
>>
>
> My suggestion would be to check
> https://tomcat.apache.org/tomcat-7.0-doc/changelog.html for changes
> between the two versions that you mentioned to find anything that could
> have changed Tomcat's behavior.
>
>
>> Is there any way or solution to trace this situation?
>>
>
> Did you test tomcat alone after the upgrade? Was it working as expected or
> was it just showing weirdness? I would start from there :)
>
> Luca
>
>



-- 
mailto:masuken@gmail.com

Mime
View raw message