httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Gingras <francois.ging...@gmail.com>
Subject Re: Fwd: Re: [users@httpd] Virtual Host Not working
Date Sun, 15 May 2016 02:19:31 GMT


On 14/05/16 07:53 PM, phil wrote:
>
> On 15/05/2016 6:16 AM, Beech wrote:
>>
>>
>>
>> -------- Forwarded Message --------
>> Subject: Re: [users@httpd] Virtual Host Not working
>> Date: Sat, 14 May 2016 21:46:41 +0200
>> From: miguel gonzalez <miguel_3_gonzalez@yahoo.es>
>> To: Beech <akbeech@gmail.com>, users@httpd.apache.org
>>
>> I always have used either the ip address or the wildcard * in the
>> virtualhost directive.
>>
>> Have you checked the logs?
>>
>> Beech <akbeech@gmail.com> wrote:
>>
>>> I have added a new virtual domain and it's not working. No error
>>> messages, just won't connect. I have triple checked the paths and
>>> spelling. DNS is propagated and dig returns the correct IP.  The other
>>> domains work. Here's the setting, it's Apache24:
>>>
>>> <VirtualHost www.greatlandfishing.com:80>
>>>     ServerAdmin akbeech@gmail.com
>>>     DocumentRoot "/usr/local/www/fishing/htdocs"
>>>     ServerName www.greatlandfishing.com
>>>     ServerAlias www.greatlandfishing.com
>>>     ErrorLog "/usr/local/www/fishing/logs/greatlandfishing-error_log"
>>>     CustomLog "/usr/local/www/fishing/logs/greatlandfishing-access_log"
>>> common
>>>     AddType application/x-httpd-php .php .phtml
>>>     AddType application/x-httpd-php-source .phps
>>> <Directory "usr/local/www/fishing/htdocs>
>
> Try changing the above line to:
>
> <Directory usr/local/www/fishing/htdocs/>
>
> reload apache, it might help . . .
>

Run apachectl -S, define all your vhosts as *:PORT, and show the output 
from the apachectl -S command after your changes.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message