httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J.D." <randomnoise...@gmail.com>
Subject [users@httpd] Apache-2.2 with LDAP authentication keeps spinning after authentication completes
Date Mon, 02 May 2016 23:22:50 GMT
Centos-6.6+seLinux, Apache-2.2, OpenLDAP-2.4.40, OpenSSL-1.0.1e-fips

Using the following sample Directory block, the Apache LDAP authentication works
just fine, but when the web page is displayed - the activity spinner is spinning
and the status bar shows "Read <hostname>". Without the Apache LDAP
authentication, neither of the above symptoms appear/occur. It is almost like
something doesn't complete/finish, but I cannot determine what causes this.
There are no messages in the HTTPD error logs relative to this situation.


<Directory "/var/www/html/directory/">
  SSLRequireSSL
  AllowOverride None
  Allow from 127.0.0.1
  Allow from localhost
  Allow from 192.168.56.0/24
# uncomment following line to force all frontend access
# to require userid/password authentication via LDAP
  include conf/WebFrontendApacheAuthentication.conf
</Directory>


WebFrontendApacheAuthentication.conf
===============================
AuthType basic
AuthName "realm"
AuthBasicProvider ldap
AuthLDAPURL ldaps://vbox-realm.vboxnet/dc=realm?uid?sub?(ObjectClass=*)
Require ldap-group cn=WebAccess,dc=realm
===============================

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message