httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vacelet, Manuel" <>
Subject Re: [users@httpd] Last-Modified header overridden
Date Mon, 06 Jun 2016 13:57:06 GMT
On Mon, Jun 6, 2016 at 1:36 PM, Vacelet, Manuel <>

> Hi Luca
> On Sat, Jun 4, 2016 at 4:54 PM, Luca Toscano <>
> wrote:
>> Can you post the list of modules that you have loaded plus your full
>> httpd config (maybe you can upload them to the bug report)?  Another think
>> to try would be to use gdb and http -X to trace one process, but it might
>> be overkill. You could also try to add trace-log specific prints in the
>> httpd .c files where Last-Modified is changed to see if anything comes up,
>> but again it might be very time consuming.
>> I tried to repro on 2.4.20 but I wasn't able, so I took a look to
>> to see if it was something
>> corrected with 2.4.13 but I didn't see anything obvious. You also mentioned
>> that there seem to be no distro specific patches applied to the httpd
>> package, so the issue might be really difficult to track.
>> Will try to check you docker image during the next days, maybe we can
>> come up with something. In the meantime, is there any possibility to switch
>> to a different httpd version (that works) to unblock you?
>> Luca
> I hoped there might be some "obvious" configuration stuff that might
> affected the behaviour but it seems to be a very specific bug.
> I don't know how to use gdb in this situation, if you have any hint, I
> would be happy to give it a try.
> I will start by rebuilding the package without the patches to see where
> the things starts to get bad.
Hmm :/
I rebuilt the package with all the patches (but one to adapt to RHEL/Fedora
layout) removed and it still doesn't work.

View raw message