httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Ivanov <andrei.iva...@gmail.com>
Subject Re: [users@httpd] mod_lua and subprocess_env
Date Wed, 22 Feb 2017 09:58:11 GMT
On Wed, Feb 22, 2017 at 2:13 AM, Yann Ylavic <ylavic.dev@gmail.com> wrote:

> On Wed, Feb 22, 2017 at 1:09 AM, Yann Ylavic <ylavic.dev@gmail.com> wrote:
> > On Tue, Feb 21, 2017 at 5:43 PM, Andrei Ivanov <andrei.ivanov@gmail.com>
> wrote:
> >> On Tue, Feb 21, 2017 at 6:32 PM, Yann Ylavic <ylavic.dev@gmail.com>
> wrote:
> >>>
> >>> On Tue, Feb 21, 2017 at 4:50 PM, Andrei Ivanov <
> andrei.ivanov@gmail.com>
> >>> wrote:
> >>> >>>
> >>> >>> Header set Client-SAN "%{PeerExtList('2.5.29.17')}s"
> >>>
> >>> The syntax may be rather:
> >>>
> >>> Header set Client-SAN "expr=%{PeerExtList:2.5.29.17}"
> >>>
> >>> Does it work better?
> >>
> >>
> >> Uf, no :-(
> >
> > I've got it to work in (in 2.4.25), with a patch (attached), and for
> > me it outputs:
> >     Client-SAN: DNS:www1.domain.tld, DNS:www2.domain.tld,
> > DNS:www3.domain.tld, IP Address:192.168.150.80, IP
> > Address:192.168.150.145, IP Address:172.25.25.100
> >
> > So I guess something like:
> >     Require expr "('IP Address:' . %{REMOTE_ADDR}) -in
> PeerExtList('2.5.29.17')"
> > should work (at least with 2.4.5).
>
> I meant 2.4.25 here...
>

So... do I have a chance to get it running on RHEL 7.3 which ships with
2.4.6?
Not sure I'll be able to convince a telecom company to patch the sources
and rebuild it themselves :-(

Thank you very much for your help and patience :-)

Mime
View raw message