httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maxim Shaydulin <>
Subject [users@httpd] Obsolete httpd-std.conf in binbuild,sh?
Date Thu, 09 Mar 2017 11:40:39 GMT
Hi all,

I'm trying to build Apache httpd server 2.4.25 on Ubuntu 4.8.0.
The idea is to embed httpd server into own application and to be able
to install on target machine in any location in file system.
I found the tool $(root src)/build/ which should do exactly
what I want.
After I run I get an archive
Then I unpack it and run <target dir> which deploys httpd.

The only problem I see is the issue with httpd.conf file. After I run, I see empty conf/httpd.conf file (and
conf/httpd-std.conf) in target directory!

I started to search what is wrong, and found that raises
this error at the end:
Binary image successfully created...
Server version: Apache/2.4.25 (Unix)
Server built:   Mar  9 2017 08:24:50
Creating supplementary files...
sed: can't read bindist/conf/httpd-std.conf: No such file or directory
Creating distribution archive and readme file...

Inside I see these lines:
chmod 755

sed -e "s%$BUILD_DIR%$DEFAULT_DIR%" \
    -e "s%^ServerAdmin.*%ServerAdmin you@your.address%" \
    -e "s%#ServerName.*%#ServerName localhost%" \
    bindist/conf/httpd-std.conf > bindist/conf/httpd.conf
cp bindist/conf/httpd.conf bindist/conf/httpd-std.conf

However I can't find httpd-std.conf is sources.
As I can see in httpd source code (FishEye), this files was deleted
more than 10 years ago. As well as

Is this a bug in, or I missed something?

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message