httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Mehler <dave.meh...@gmail.com>
Subject [users@httpd] apache 2.4 and mod_perl2
Date Tue, 27 Feb 2018 15:37:55 GMT
Hello,

I'm trying to get apache 2.4 and mod_perl2 in my case 2.0.10 going on
a FreeBSD 11.1 system.

I've got this in a virtual host section:

#
# mod perl per-directory configuration
#

# Required modules: dir_module, perl_module
<IfModule dir_module>
        <IfModule perl_module>
                DirectoryIndex index.pl
        </IfModule>
</IfModule>

Alias "/perlweb/" "/usr/local/www/perlweb/"
<Location "/perlweb/">
      AddHandler perl-script .pl
      AddHandler perl-script .cgi
      PerlResponseHandler ModPerl::Registry
      PerlOptions +ParseHeaders
      Options +ExecCGI
Require all granted
</Location>



I'm getting a syntax error on the PerlResponseHandler line invalid command.

Anyone got any ideas how I can fix?

Thanks.
Dave.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message