httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Gruno <humbed...@apache.org>
Subject Re: [users@httpd] Running Lua Script using mod_lua
Date Thu, 17 May 2018 06:23:59 GMT
On 05/17/2018 08:21 AM, Luca Toscano wrote:
> Hi,
> 
> 2018-05-16 12:22 GMT+02:00 Hemant Chaudhary 
> <hemantdude.chaudhary@gmail.com <mailto:hemantdude.chaudhary@gmail.com>>:
> 
>     Hi,
> 
>     While running lua_script using mod_lua, I am getting this error in
>     error_log. What does it mean
>     "PANIC: unprotected error in call to Lua API (core and library have
>     incompatible numeric types)"
> 
> 
> What version of Lua are you using? You can quickly check with something 
> like ldd /usr/local/apache2/modules/mod_lua.so. It might be a mismatch 
> between what you are trying to execute (the script) and what you are 
> using as interpreter (mod_lua), but I haven't investigated it very well 
> so I might be wrong :)

Almost! :)
It's an incompatibility between mod_lua's lua lib (typically 5.1 or 5.2) 
and a library that is being used (likely made for 5.3?). There were 
fundamental changes to how numbers work in 5.3, if I remember correctly, 
so you would either have to use a library that works with 5.1/5.2, OR 
recompile mod_lua with the 5.3 library and headers.

> 
> Hope that helps,
> 
> Luca


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message