httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Gardiner <li...@glidos.net>
Subject [users@httpd] gitweb permission problems with new install
Date Fri, 15 Jun 2018 15:19:49 GMT
openSUSE Leap 42.3, Apache 2.4.23:
   I have gitweb working just fine.

openSUSE Leap 15.0, Apache 2.4.33:
   gitweb cannot access my git repository
   Shows error: "gitweb.cgi: Can't opendir(/export/git): Permission 
denied: /usr/share/gitweb/gitweb.cgi"


I've searched through the apache config and can find no differences, 
other than on 42.3 user wwwrun has group www, whereas on 15.0 it has 
group wwwrun and is also a member of www. /export/git has group www. 
I've tried changing it to wwwrun. That changes the error to: 
"gitweb.cgi: Can't cd to /export/git: Permission denied: 
/usr/share/gitweb/gitweb.cgi"

I'm loading exactly the same set of apache modules, other than one uses 
php5 and the other php7 (gitweb.cgi is written in perl).

Leap 15.0 includes apparmor, but I see no messages from it. I've tried 
stopping apparmor to no effect.

Can anyone suggest a way to track down the cause?

Cheers,
	Paul.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message