httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rose, John B" <jbr...@utk.edu>
Subject Re: [users@httpd] Apache Will Not Start
Date Wed, 29 Aug 2018 01:50:53 GMT
Do you have a /var/run/httpd directory?

Sent from my iPad

On Aug 28, 2018, at 9:48 PM, Alex Nyamweya <animesonic94@gmail.com<mailto:animesonic94@gmail.com>>
wrote:

Hi,

I am running an Apache server with CentOS 7 installed. I'm having issues starting apache using
the command systemctl status httpd.service as I would get the following message:

Job for httpd.service failed because the control process exited with error code. See "systemctl
status httpd.service" and "journalctl -xe" for details.

Here is the output of systemctl status httpd:

httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2018-08-29 02:46:48 CEST; 42s ago
     Docs: man:httpd(8)
           man:apachectl(8)
  Process: 9599 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
  Process: 9597 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 9597 (code=exited, status=1/FAILURE)

Aug 29 02:46:48 [server-name] systemd[1]: Starting The Apache HTTP Server...
Aug 29 02:46:48 [server-name] httpd[9597]: (98)Address already in use: AH00072: make_sock:
could not bind to address [my-ip-address]:443
Aug 29 02:46:48 [server-name] httpd[9597]: no listening sockets available, shutting down
Aug 29 02:46:48 [server-name] httpd[9597]: AH00015: Unable to open logs
Aug 29 02:46:48 [server-name] systemd[1]: httpd.service: main process exited, code=exited,
status=1/FAILURE
Aug 29 02:46:48  [server-name] kill[9599]: kill: cannot find process ""
Aug 29 02:46:48  [server-name] systemd[1]: httpd.service: control process exited, code=exited
status=1
Aug 29 02:46:48 [server-name] systemd[1]: Failed to start The Apache HTTP Server.
Aug 29 02:46:48 [server-name] systemd[1]: Unit httpd.service entered failed state.
Aug 29 02:46:48 [server-name] systemd[1]: httpd.service failed.

Here is what I tried so far. I tried checking if any process is running on port 443 using
the command netstat -an | grep 443, but it showed nothing.

I tried checking the httpd.conf and ssl.conf files and see if there is a 'Listen 443' on both
but there isn't. It is only in ssl.conf.

That's all I've tried so far but I'm open to any suggestions you may have.
Mime
View raw message