Please change your worker parameter naming convention in regards to MAX.
Why? I completely misunderstood the difference between ThreadLimit and ThreadsPerChild. I have wasted over 8 hours researching the difference.
Try this out:
It is obvious what the relationship is between parameters with and without the prefix “max”. Compare these ThreadLimit and ThreadsPerChild. Following my proposed standard makes the relationship obvious.
I agree that the naming can be surprising, but https://httpd.apache.org/docs/2.4/en/mod/mpm_common.html#threadlimit is, IMHO, clear enough.
A similar explanation should be added in https://httpd.apache.org/docs/2.4/en/mod/mpm_common.html#threadsperchild to help figure out the relationship between these 2 directives.