httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan.SYK...@rb.cz
Subject [users@httpd] Segmentation fault when builded with openssl 1.1.1
Date Mon, 28 Jan 2019 14:36:10 GMT
Hi,

I have an issue with version httpd 2.4.38 when it is builded with openssl 
1.1.1 and mod_cluster
There are repeated error messages in error.log:

AH00052: child pid xxxx exit signal Segmentation fault (11)

These error messages are suppressed when mod_ssl is disabled 

Builded on Linux 3.10.0-693.1.1.el7.x86_64

httpd server builded with:

APR=apr-1.6.5.tar.gz
APR_UTIL=apr-util-1.6.1.tar.gz
HTTPD=httpd-2.4.38.tar.gz
LIBXML=libxml2-2.9.7.tar.gz
M4=m4-1.4.18.tar.gz
MOD_CLUSTER=mod_cluster-1.3.10.Final.tar.gz
MOD_SECURITY=modsecurity-2.9.2.tar.gz
NGHTTP2=nghttp2-1.36.0.tar.gz
OPENSSL=openssl-1.1.1a.tar.gz
PCRE=pcre-8.42.tar.gz

Do you have any idea what could be wrong or it is possible bug in actual 
version of httpd server? Because when i tried to build httpd 2.4.37 with 
same prerequesities with same way and also with openssl 1.1.1 there is no 
problem with this combination.

Thanks
Jan


Mime
View raw message